OS-OE Knowledge/Linux-Unix KB118 RHEL7/NIC interface ethx 사용 (NIC Naming Convention) RHEL7에서 NIC 장치의 명명 규칙이 변화를 갖었다. RHEL 7 the names have two character prefixes based on the type of interface:en for Ethernet,sl for serial line IP (slip),wl for wireless LAN (WLAN),ww for wireless wide area network (WWAN). 과거의 ethx 로 장치명을 사용하기 위해1. MAC Address 확인[root@RH71 ~]# ip link1: lo: mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:002: .. 2015. 5. 16. RHEL7/VNC Server 설치/구성 RHEL7에 VNC 접근을 위해 VNC 서버를 설치 및 구성해보자. 1. VNC 관련 패키지 설치 (택 일)# yum install vnc*or # yum install tigervnc-server 2. VNC 에 접근시 사용할 Password 구성# vncserver; vncserver -kill :1----------Input vnc password :---------- 2. VNC 관련 GUI 패키지 설치# yum groupinstall 'X Window System' 'Desktop' 3. VNC를 통해 접근 시 사용할 해상도 지정# vncserver -geometry 1280x768 4. VNC 접근에 사용할 구성파일 편집# cp /lib/systemd/system/vncserver@.servi.. 2015. 5. 16. Why does yum return error: [Errno 256] No more mirrors to try ? Why does yum return error: [Errno 256] No more mirrors to try ?https://access.redhat.com/solutions/203603 Issue[Errno 256] No more mirrors to try. Resolution# rm -fr /var/cache/yum/*# yum clean all# yum repolist all 2015. 5. 16. RHEL7 - Build Repository RHEL7 설치 후 DVD media를 사용해 Repository 구성하기. 1. DVD 미디어를 마운트# mkdir -p /media/RH7-DVD # mount -o loop /dev/cdrom /media/RH7-DVD 2. Repo 구성 파일 생성/편집# vi /etc/yum.repos.d/RH7-DVD.repo아래 내용과 유사하도록 편집 -------------------[RHEL7-DVD]NAME=RHEL7-DVDBASEURL=file:///media/RH7-DVDENABLED=1GPGCHECK=0------------------------------------------ 3. 지속적으로 사용하기 위해 등록(선택)# vi /etc/fstabAppend below line ------------.. 2015. 5. 16. SUSE/panics on reboot after shutting down Oracle services OS : SUSE Linux Enterprise Server 11 (x86_64) VERSION = 11 PATCHLEVEL = 2 Kernel : 3.0.13-0.27-default oracleasm SUSE Linux Enterprise 11 2.0.5-7.24.59 oracleasm-kmp-default SUSE Linux Enterprise 11 2.0.5_3.0.13_0.27-7.24.59 kernel: [93272.425238] slab error in kmem_cache_destroy(): cache `asmdisk_cache': Can't free all objects kernel: [93272.425248] Pid: 88504, comm: modprobe Tainted: G X 3.0.1.. 2015. 3. 27. Ubuntu/명령 수행 시 관리자 권한 여부에 대한 Password 질의 무시 /etc/sudoers : sudo 명령 사용시 사용자가 따라야 하는 규칙 정의 파일 c.f.)root ALL=(ALL) ALL 사용자 root는 모든(ALL) 터미널에서 명령을 수행가능/모든(ALL) 사용자의 권한을 지님/모든 명령을 수행가능 참고: http://www.garron.me/en/linux/visudo-command-sudoers-file-sudo-default-editor.html # sudo - # echo " ALL=(ALL) NOPASSWD: ALL">>/etc/sudoers # exit username이 수행하는 명령에 대하여 관리자 권한 보유 여부에 대한 Password 질의 없이 명령 수행 2015. 3. 5. ARP Neighbour table overflow Model : DL360p Gen8 Linux OS 운영 중 Application(HP Insight Cluster Management Utility (CMU)) 수행 시 아래와 유사 메시지가 출력되며 정상 수행되지 않음. [error] risk of arp neighbor table overflow on this mgt node [error] set /proc/sys/net/ipv4/neigh/default/gc_thresh1 to >= 268 원인 : ARP cache overflow - OS 운영 중 ARP neighbor table이 조금씩 누적 증가하여 임계값을 초과하게 되어 해당 테이블을 참조하는 CMU 서비스가 정상적으로 구동되지 못함 - 이는 리눅스 운영 환경에 일반적으로 경험할 수 있는 .. 2014. 12. 18. RHEL/5.4 or 5.5 운영 시 blocks=XX, block_size=XX, heads=XX, sectors=XX, cylinders=XX 메시지가 로깅됨 Model : DL380 G6 OS : CentOS 5.5 운영 중 OS event log(/var/log/messages)에 아래와 유사 메시지가 반복적으로 발생 ----------------------------------------------------------- kernel: blocks= 585871964 block_size= 512 kernel: heads= 255, sectors= 32, cylinders= 71799 ----------------------------------------------------------- Running HP vendor supplied command 'hpacucli', frequently shows "blocks=XX, block_size=XX, hea.. 2014. 12. 18. What is RCU(Read-copy-update) and RCU stall? RCU(Read-copy-update)는 IO 가 Read에 비정상(?)적으로 집중되는 시스템에서 데이터의 무결성(?)을 보존하기 위한 기법으로 lock(R/W 모두 hold하기 때문에 IO 병목 유발) 알고리즘 대신 사용하는 기술(Read는 필요할 때 지속 수행, Write를 RCU가 모니터링 하다가 기회가 생길때 수행되며, Read 작업으로 인해 여러개 버전의 데이터가 생성될 수 있고, 구 버전은 데이터의 사용이 만료될 때 삭제됨)이다. RCU Stall이라 함은, 위의 RCU 엔진이 어떠한 원인으로 먹통(stall)이 되는 경우로, 일반적으로 CPU 사용율이 비정상적으로 높아(100%) 다른 업무 수행이 불가능할 때 등에 발생. In computer operating systems, read-cop.. 2014. 12. 9. 이전 1 ··· 3 4 5 6 7 8 9 ··· 14 다음 반응형